Echo in repeater audio

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Echo in repeater audio

KB1NYT
Hello

Another question. This is a repeater setup with a Raspberry Pi and two
TYT radios as the repeater. Using GPIO for PTT and PL Detect. The sound
card is USB. Everything is working except there is an echo in the audio.
The repeater IDs fine no echo. I can put it in parrot mode no echo. I
can use DTMS to bring up help and get info no echo. All this I am doing
at the same site as the repeater setup my house. If I talk to a friend
in a mobile there is an echo in both directions. What would cause this?

Thanks

Jay

KB1NYT


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Svxlink-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/svxlink-devel
Reply | Threaded
Open this post in threaded view
|

Re: Echo in repeater audio

Gustavo Conrad
Hi Jay, I guess that the problem is that your setup is connecting rx to
tx audio on 2 paths at the same time. Check if your interface cable is
not bypassing the audio from rx to tx. Another chance is that the audio
is being played back by the audio system, check the audio mixer
(alsamixer) and turn off the audio input playback.

73!

Gustavo - LU8WFY

On 01/05/2017 11:07 PM, KB1NYT wrote:

> Hello
>
> Another question. This is a repeater setup with a Raspberry Pi and two
> TYT radios as the repeater. Using GPIO for PTT and PL Detect. The sound
> card is USB. Everything is working except there is an echo in the audio.
> The repeater IDs fine no echo. I can put it in parrot mode no echo. I
> can use DTMS to bring up help and get info no echo. All this I am doing
> at the same site as the repeater setup my house. If I talk to a friend
> in a mobile there is an echo in both directions. What would cause this?
>
> Thanks
>
> Jay
>
> KB1NYT
>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
> _______________________________________________
> Svxlink-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/svxlink-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Svxlink-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/svxlink-devel